Showbie is online and this issues have now been resolved. Thank you for your patience.
Posted Oct 20, 2025 - 21:15 UTC
Monitoring
AWS has fixed the issue and we are seeing early signs of recovery. Requests are succeeding but there are still slowness issues as our instances scale up.
Posted Oct 20, 2025 - 17:50 UTC
Identified
AWS is still investigating the root cause of network connectivity issues. The Showbie App is still unstable and users are experiencing intermittent availability.
Posted Oct 20, 2025 - 16:07 UTC
Monitoring
AWS has fixed the issue and we are seeing significant signs of recovery. Requests are succeeding but there are still slowness issues as our instances scale up.
Posted Oct 20, 2025 - 11:18 UTC
Identified
AWS has identified the issue. You can view the details for AWS investigation and recovery efforts live on their status page located at: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 09:15 UTC
Investigating
Our main cloud hosting provider Amazon Web Services (AWS) is experiencing an outage impacting areas of the Showbie App.
Posted Oct 20, 2025 - 09:11 UTC
This incident affected: US Region (Showbie Core) and EU Region (Showbie Core).